United Kingdom | english

What PSS 4000 firmware version should I use?

Pilz always recommends to use the latest firmware version!

Attention! Only use PSS 4000 Version 1.6.1 firmware or higher, if you consider to go into production. If you may have further questions don't hesitate to contact our Technical Support at +49 711 3409-444, support@pilz.com

Contact

Pilz Automation Ltd
Pilz House, Little Colliers Field
Corby, Northants, NN18 8TJ
United Kingdom

Telephone: +44 1536 460766
E-Mail: sales@pilz.co.uk

Technical Support

Telephone: +44 1536 462203
E-Mail: techsupport@pilz.co.uk